أكثر

PostgreSQL - خطأ ارتباط PostGIS

PostgreSQL - خطأ ارتباط PostGIS


لدي قاعدة بيانات شاهدتها في QGIS باستخدام PostGIS.

تمكنت من ربطهم باستخدام مجموعة قواعد البيانات والمضيف correst في العام الماضي. أنا الآن أقوم بزيارة العمل مرة أخرى ولا يمكنني ربطهما مرة أخرى. يتم تثبيت الامتدادات المناسبة في Postgres (أنا استخدم pgadmin) ، وهي postgis و postgis_topology. ومع ذلك ، عند الاتصال من خلال QGIS ، تقول أنه لا يمكنني الاتصال.

بعد أن حصلت على استكشاف في قاعدة بيانات postgres الخاصة بي في pgadmin ، أتلقى الخطأ التالي عندما أنقر على الجداول المكانية:

تعذر تحميل المكتبة "/usr/pgsql-9.2/lib/postgis-2.0.so": / usr / pgsql- 9.2 / lib / postgis-2.0.so: رمز غير محدد: pj_get_spheroid_defn

إصدار postgres هو: 9.2.10

عندما أطلب إصدار postgis تظهر نفس رسالة الخطأ.


يبدو لي أنه ربما تم تجميع PostGIS الخاص بك باستخدام مشروع أحدث مما قمت بتثبيته. ما هي مكتبة proj التي قمت بالتثبيت بها؟

قد تفقد أيضًا مكالمة ldconfig.